Power Diary - M icon for Medicare Claiming is not working - workaround available – Incident details

All systems operational

M icon for Medicare Claiming is not working - workaround available

Resolved
Operational
Started 2 months agoLasted about 10 hours

Affected

AU/Global Infrastructure

Operational from 3:41 AM to 2:05 PM

AU/Global - Main Application

Operational from 3:41 AM to 2:05 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We're actively working on a fix for Medicare claiming not being available via the "M" icon. This issue is being addressed as a top priority.

    In the meantime, please navigate to Edit Invoice > Medicare to process your claims.

    Thank you for your patience and understanding!