Power Diary - 504 Gateway Timeout Error – Incident details

All systems operational

504 Gateway Timeout Error

Resolved
Partial outage
Started 2 months agoLasted about 1 hour

Affected

AU/Global Infrastructure

Partial outage from 3:45 PM to 4:34 PM

AU/Global - Main Application

Partial outage from 3:45 PM to 4:34 PM

Updates
  • Resolved
    Resolved

    Started at around 14:58 UTC

    Ended at around 15:15 UTC

    We appreciate your patience as we address the recent issue you may have experienced. Our engineering team has identified that this issue was partially due to an external library we use to manage connections to our caching services. We have implemented improvements to enhance the reliability of these connections and optimize resource utilization.

    These updates include adjustments to our connection mechanisms and an increase in the minimum resources required to ensure smoother operations, especially during peak system usage.

  • Investigating
    Investigating

    We are aware that some users are experiencing a 504 Gateway error when accessing Power Diary. Our engineers are investigating as a priority and we will update this page with further information as soon as possible, and appreciate your patience during this time.