All systems operational

Server Upgrade

Completed
Scheduled for 17 May, 2024 at 1:00 AM – 1:30 AM

Affects

US Infrastructure
US - Main Application
US - Client Portal
UK Infrastructure
UK - Main Application
UK - Client Portal
Updates
  • Completed
    17 May, 2024 at 1:30 AM
    Completed
    17 May, 2024 at 1:30 AM

    Maintenance was completed. Databases in the UK and US regions have been upgraded to improve the system's performance in both regions.

  • In progress
    17 May, 2024 at 1:00 AM
    In progress
    17 May, 2024 at 1:00 AM
    Maintenance is now in progress
  • Planned
    17 May, 2024 at 1:00 AM
    Planned
    17 May, 2024 at 1:00 AM

    We are planning for a scheduled maintenance to upgrade our Server for the UK and US environments during that time.

    • When: 2AM-2:30AM UK, 9PM-9:30PM EST US

    • Duration: a few minutes of downtime during the time window mentioned above

    We thank you for your understanding!