All systems operational

AU/Global Infrastructure

Operational

AU/Global - Main Application

99.93% uptime

AU/Global - Client Portal

99.99% uptime

US Infrastructure

Operational

US - Main Application

99.97% uptime

US - Client Portal

100.0% uptime

UK Infrastructure

Operational

UK - Main Application

99.97% uptime

UK - Client Portal

100.0% uptime

Recent notices

18 April, 2024

Printing or Emailing any documents results in an error
  • Resolved
    Resolved

    This incident has been resolved. Generating PDF invoices, letters and sending invoices/receipts via email should now work as expected.

    We'd again like to thank you for your patience during this time, and do email support@powerdiary.com if you have any follow-up queries or experience related issues.

  • Identified
    Identified

    We have identified the root cause, but not a complete fix at the time of writing.

    As a potential workaround, removing your business logo image from invoices/receipts (Settings > Configuration > Invoices) allows the generated PDF to work as expected.

    We continue to work on resolving the issue entirely and appreciate your continued patience during this time.

  • Investigating
    Update

    Engineers are continuing to investigate this, and looking for solutions. We apologise for the inconvenience caused during this time.

  • Investigating
    Update

    We are continuing to investigate this incident.

  • Investigating
    Update

    Our engineers are currently looking into this at a high priority. We appreciate your continued patience during this time.

  • Investigating
    Investigating

    We are investigating error messages when:

    1. Attempting to email or print an invoice/receipts or

    2. When attempting to send a letter via email as an attachment

    3. When attempting to export a generated letter as a PDF file.

    We will update this page with further information as soon as possible, and appreciate your patience during this time.

17 April, 2024

16 April, 2024

15 April, 2024

14 April, 2024

13 April, 2024

12 April, 2024

Show notice history